0 votes
51 views
by Rookie

Hello,

Wen I run command: 

sudo webinoly -verify

 After Upgrade Ubuntu 18.04, I saw:

Verifying integrity of the entire Webinoly system...

[INFO] File: /etc/nginx/.htpasswd not found!

[ERROR] File: /usr/bin/letsencrypt not found!

[INFO] PHP v7.3 is recommended to get an optimal perfomance!

[INFO] MariaDB (MySQL) v10.3 is recommended to get an optimal perfomance!

*******************************************************

********      > > >  E R R O R < < <        ***********

********   System could not work properly   ***********

*******************************************************

How to fix it? 

Thank you so much.

1 Answer

0 votes
by Expert

This seems like it has nothing to do with your Ubuntu upgrade, the only thing that caught my attention is the error you are getting for "letsencrypt", did you remove it manually? if not, please just run sudo certbot renew to check if it's installed and working.

For the other things, please just read the docs and upgrade PHP and MySQL to the latest versions.

by Rookie

Hello, 

root@ns1:~# sudo certbot renew

sudo: certbot: command not found

How to fix it ? 

[INFO] File: /etc/nginx/.htpasswd not found!

Where's it ? 

[ERROR] File: /usr/bin/letsencrypt not found!

Where's it? How to fix ?

 root@ns1:~# sudo webinoly -info

[SYSTEM]

Operating System: Linux version 4.15.0-48-generic (buildd@lgw01-amd64-036) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019

Description:    Ubuntu 18.04.2 LTS

Codename:       bionic

[PHP]

PHP 7.3.5-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: May 3 2019 10:00:24) ( NTS )

[MYSQL]

mysql  Ver 15.1 Distrib 10.2.23-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

PhpMyAdmin: 4.8.5

 I've upgrade 16.04 to 18.04 success. 

How to change MariaDB 10.2 to 10.3 ? 

by Expert

Send me the output of: sudo webinoly -info 

Also, I can't help you if you don't respond to my questions and please read the documentation instead just asking "how to fix it".

by Rookie

Hello,

I think upgrade 18.04 and Webinoly 1.8, they're include MariaDB 10.3.

So sorry.

sudo webinoly -info 

[SYSTEM]

Operating System: Linux version 4.15.0-48-generic (buildd@lgw01-amd64-036) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019

Description:    Ubuntu 18.04.2 LTS

Codename:       bionic

Cores: 1

RAM: 2Gb

SWAP: 1Gb

File descriptors: 147433

[Disk Usage]

Filesystem     Type  Size  Used Avail Use% Mounted on

/dev/vda1      ext4   40G   11G   27G  28% /

[NGINX]

nginx branch: stable

nginx version: nginx/1.14.2

nginx file descriptors: 398034

worker_processes: auto

worker_connections: 8192

worker_rlimit_nofile: 398034

client_max_body_size: 50m

[CACHE]

FastCGI 200: 30d

FastCGI 3xx/4xx: 1m

FastCGI inactive: 7d

FastCGI max-size: 388m

open_file_cache_valid: 3m

open_file_cache max: 132678

open_file_cache inactive: 5m

[PHP]

PHP 7.3.5-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: May 3 2019 10:00:24) ( NTS )

memory_limit:  192M

post_max_size:  50M

upload_max_filesize:  50M

max_file_uploads:  20

max_execution_time:  300

[MYSQL]

mysql  Ver 15.1 Distrib 10.2.23-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

PhpMyAdmin: 4.8.5

[Raw Conf]

pre-packs:true

nginx-ppa:stable

nginx:true

tools-port:

nginx-tool:true

mysql-client:true

mysql-root:

mysql-admin:

mysql:true

swap-owner:webinoly

app-version:1.8.0

linux-optim:true

wp-admin-auth:purged

yoast-sitemap:true

server-version:1.3

nginx-optim:true

php-v7.2:purged

php-ver:7.3

php:true

php-v7.3:true

php-optim:true

php-tool:true

mysql-tool:true

status-api:wys

by Expert

Seems like only Certbot was uninstalled for an unknown reason in the Ubuntu upgrade process. If you need it, you must re-install it manually:

sudo add-apt-repository ppa:certbot/certbot
sudo apt -y install certbot

If you want to upgrade MariaDB, just read the docs. Everything else seems fine.

And just for the record, one of the main benefits of using "the cloud" is that you can spin up new servers very easily. I recommend you should run a new and fresh server instead of upgrading your operating system.

Welcome to the Community site for Webinoly.

If you have a question about Webinoly, please ask in English or Spanish.

To report a bug, please ask a question here with the bug tag.

News: Now you can use any external SMTP service in your server. All the server outgoing emails from any of your websites will be sent through this service.

Donations

Webinoly Support Paypal Donations Webinoly Support Bitcoin Donations

Your regular donations is what keep this project moving forward. If you like Webinoly, buy me a coffee or a beer to show support.

Affiliate Links

It is very important that any visitor to the site read the disclaimer, terms of use and privacy and legal statement before start browsing.

...