Webinoly is just the perfect tool for NGINX experts. Give it a try!
0 votes
685 views
by Talented
Hi ! We did a new / fresh install with the latest webinoly, and we have often 504 errors (time out) from Nginx when we want, by example, load the plugins page on the backend of wordpress.

We saw these error messages in the log :

[error] 14636#14636: *1 upstream timed out (110: Connection timed out) while reading response header from upstream, client: X.XX.XXX.XX, server: xxxx-xxxxxx.com, request: "GET /wp-admin/plugins.php HTTP/2.0", upstream: "fastcgi://127.0.0.1:9000", host: "xxxx-xxxxxx.com", referrer: "https://xxxx-xxxxxx.com/wp-admin/"

When trying to load the plugins page, it loads like 10/15 seconds and go to the 504 error page of Nginx.

Any idea about that issue ? (we have the defult parameters of Webinoly, and the wordpress website is not heavy at all, with just like 8 plugins and a wordpress basic theme).

Nb : in another server with the previoux version of Webinoly, we never have that issue.

Thanks for your support !

Regards
by Expert
Maybe related to this issue: https://webinoly.com/support/2261/nginx-helper-timing-out-page-when-purge-cache-buttons-pressed

Seems like Nginx-Helper plugin was causing issues and it's now solved in a new release.
by Rookie
This things happen today with updated webinoly 1.13.2 (I Updated Today) in all vps instances. Then all of my wordpress sites hosted in vps instances are down with 502 error page when I published new post.

So I Delete ngix-helper plugin and all are fine now.
by Rookie
Not Ok At All, Keep down from time to time with 504 page.

1 Answer

0 votes
by Expert

The new or latest versión can not be the cause, because the stack was not modified. If you check the webinoly versión sudo webinoly -version, you will see that the stack is not always updated.

Sometimes an oudated package in your operating system can cause these kind of issues, you should try:

sudo apt update && sudo apt upgrade -y
sudo reboot

Regards.

by Talented
reshown by
Hi QRokes ...

It gives me webinoly 1.10.0 + stack 1.4 (1.4 is the latest am I correct?)... all packages are also up to date ...

I'll have to dig in the logs when I have the time and see if there's something going on.
Welcome to the Community site for Webinoly.

Our Optimized LEMP Web Server is a powerful set of commands for doing just about anything you could wish.

With Webinoly you can set up your NGINX web server in just one step.

* * * * * * *

To report a bug, please create a new issue on GitHub or ask a question here with the bug tag.
Webinoly Support Paypal Donations

PayPal · GitHub Sponsors · Bitcoin

It is very important that any visitor to the site read the disclaimer, terms of use and privacy and legal statement before start browsing.

...