Webinoly is just the perfect tool for NGINX experts. Give it a try!
0 votes
91 views
by Rookie
Hi, first of all I'd like to say that I am REALLY impressed with Webinoly for multisites.

I think I am having some sort of bug or maybe I missed some part of the instructions.

I followed the full guide and created a multisite using subdomains.

I then created a SSL for the main website. I am able to create subsites from the dashboard with no problem, and have edited wp-config in order to fix the cookies.

Now I am facing two problems:

1. Whenever I set a new parked domain, my main site gets redirected to the newly created parked domain and I have to go to phpmyadmin and edit the wp_options table in order to set the URL back to the right URL. I guess I must be doing something wrong here.

2. When the new site is created, the SSL has a common name mismatch. Is it something I am doing wrong at the DNS provider? Do I need to set an extra parameter when I am creating the certificate?

Thank you very much.
by Expert

Can you confirm if it's the same issue like the described here: SSL for parked domain not Valid - Webinoly Community

by Rookie
Sounds like it could be. The weirdest thing is that the main site wp_options is being overwritten. Is this expected behaviour?
by Expert
Mmmm... can you please elaborate on the detailed steps to reproduce this issue.
by Rookie

Sure I can!

I started with 

wget -qO weby qrok.es/wy && sudo bash weby 3

then

sudo webinoly -conf-value_max-mb-uploads=200
sudo webinoly -conf-value_nginx-ppa=mainline
sudo webinoly -timezone=America/Sao_Paulo

sudo site mainsite.com -wp -env=development

sudo site mainsite.com -ssl=on
sudo site mainsite.com -multisite-convert
Then I edited wp-config, went to the dashboard, created the network as a subdomain, and created a website.
Went to cloudflare, pointed the new domain as a A domain to the same IP as the main site.
sudo site newdomain.com -parked=mainsite.com
sudo site newdomain.com -ssl=on -root=mainsite.com
at this point, when I tried accessing the main website it redirected to the newly created parked domain.
i then had to go to my database and edit the wp_options to fix the addresses.
actual live examples:
https://landingpages.desenro.la (mainsite)
https://landing1.desenro.la (subsite)
https://novosubdominio.desenro.la (subsite)

1 Answer

0 votes
by Expert

First of all, seems like you're trying to domain mapping the main site, that makes no sense, if you want to do that just create the main site using the domain you want. Domain Mapping is for subsites.

Also, you don't need to edit the wp-config file, and also it's not a good idea to report a server issue using Cloudflare.

by Rookie

Well, that is not what I intended to do. I only mapped different domains for the subsites, and the only parked domains I added were for the subsites or else I'd get to the nginx default page.

Is there any information I misunderstood from the tutorials?

Also, what do you mean by "it's not a good idea to report a server issue using Cloudflare"? Sorry if sounds like a basic question.

by Rookie
According to the answer on the other topic, my mistake seems to be creating a parked domain using the command above.

What should be the right use of the parked command? What is the right way to tell Webinoly that I am pointing a new domain to the server and have it go to the subsite that I created on the network?
by Rookie

According to the full tutorial:

To create the new site for the school we have decided to use this option. We created a new site in the Multisite installation: example.com/school, which we will access using the new domain www.example.edu, making the modifications described in the official documentation.

sudo site example.edu -parked=example.com

That is exactly what I did.

I created https://landingpages.desenro.la as the mains website with subdomain option.

Next site is created as subsite.landingpages.desenro.la, so I go to the domain mapping section and changed it to https://landing1.desenro.la.

When I run the parked domain option, shouldn't it be as follows?

sudo site landing1.desenro.la -parked=landingpages.desenro.la

by Expert
Ok. I think I was able to reproduce this issue and now it was fixed for the next release (v1.14.0). When SSL is enabled in the main site, parked sites created was failing to update the DB, it was fixed and now DB is updated correctly for subsites.
by Rookie
Thanks a bunch! Is there an estimate for the release date?
by Expert

The estimated date for the next release is always published here: PLEASE: Read before posting - Webinoly Community

by Rookie
Thank you very much!
by Rookie
Hi, sorry to bother but are there any news regarding this release?
Welcome to the Community site for Webinoly.

Our Optimized LEMP Web Server is a powerful set of commands for doing just about anything you could wish.

With Webinoly you can set up your NGINX web server in just one step.

* * * * * * *

To report a bug, please create a new issue on GitHub or ask a question here with the bug tag.
Webinoly Support Paypal Donations

PayPal · GitHub Sponsors · Bitcoin

It is very important that any visitor to the site read the disclaimer, terms of use and privacy and legal statement before start browsing.

...