Webinoly is just the perfect tool for NGINX experts. Give it a try!
0 votes
125 views
by Talented

Just updated to the last version of webinoly (Webinoly version: 1.14.1 / Current stack version: 1.6) and after doing an update and upgrade nginx is held back.

--with-new-pkgs doesn't solve it. Never seen that before, but I don't know if this is a bug or something I should try to figure out.

Any opinions anyone?
 

1 Answer

0 votes
by Rookie

I have the same problem

lsb_release -r

Release: 18.04

The following packages have been kept back:

  nginx

0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

sudo webinoly -version

Webinoly version: 1.16.4

Current stack version: 1.7

 sudo nginx -V

nginx version: nginx/1.20.1

built with OpenSSL 1.1.1  11 Sep 2018

TLS SNI support enabled

configure arguments: --with-cc-opt='-g -O2 -fdebug-prefix-map=/build/nginx-kLXxPU/nginx-1.20.1=. -fstack-protector-strong -Wformat -Werror=format-security -fPIC -Wdate-time -D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now -fPIC' --prefix=/usr/share/nginx --conf-path=/etc/nginx/nginx.conf --http-log-path=/var/log/nginx/access.log --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock --pid-path=/run/nginx.pid --modules-path=/usr/lib/nginx/modules --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --with-compat --with-debug --with-pcre-jit --with-http_ssl_module --with-http_stub_status_module --with-http_realip_module --with-http_auth_request_module --with-http_v2_module --with-http_dav_module --with-http_slice_module --with-threads --with-http_addition_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_sub_module

by Expert
Most of the time it happens because for some reason you (unintentionally) have removed (or modified) the package PPA.
by Rookie

I don't think I've modified or deleted any PPAs

sudo ls /var/lib/apt/lists/ | grep nginx

nginx.org_packages_ubuntu_dists_bionic_InRelease

nginx.org_packages_ubuntu_dists_bionic_nginx_binary-amd64_Packages

The nginx version is 1.20.1. I think 1.20.2 is the newest version and it is listed in the Packages file.

1.22 just came out.

by Rookie

I get this error when trying to upgrade it directly.

sudo apt-get upgrade nginx

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

 libnginx-mod-brotli : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-http-auth-pam : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-http-dav-ext : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-http-echo : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-http-geoip : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-http-geoip2 : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-http-image-filter : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-http-subs-filter : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-http-upstream-fair : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-http-xslt-filter : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-mail : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-ssl-ct : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-stream : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-stream-geoip : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 libnginx-mod-stream-geoip2 : Depends: nginx-common (= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

 nginx-full : Depends: nginx-core (>= 1.20.1-2+ubuntu18.04.1+deb.sury.org+1) but it is not going to be installed

              Depends: nginx-core (< 1.20.1-2+ubuntu18.04.1+deb.sury.org+1.1~) but it is not going to be installed

E: Broken packages

by Expert
As I said before, your PPA seems to be corrupted.
Welcome to the Community site for Webinoly.

Our Optimized LEMP Web Server is a powerful set of commands for doing just about anything you could wish.

With Webinoly you can set up your NGINX web server in just one step.

* * * * * * *

To report a bug, please create a new issue on GitHub or ask a question here with the bug tag.
Webinoly Support Paypal Donations

PayPal · GitHub Sponsors · Bitcoin

It is very important that any visitor to the site read the disclaimer, terms of use and privacy and legal statement before start browsing.

...